use strict;
my $str = 'CORPORATION SERVICE COMPANY 301 S BEDFORD STE 1 MADISON WI 53703 3175 COMMERCIAL AVE STE 201 NORTHBROOK IL 60062 USA';
my $regex = qr/(((.*) (Waukesha|MADISON|NORTHBROOK) (\w{2,}) (\d+(( \d+)*)) \w+) ((.*) (Waukesha|MADISON|NORTHBROOK) (\w{2,}) (\d+)))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}