import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\p{L}.*?(?=\\s*\\()";
final String string = "M.Joan (13-2) \n"
+ "A.Alfred (20-13) \n"
+ "F.O'Neil (12-231) \n"
+ "D.Dan Fun (23-3)\n"
+ "T.Collins (51-82) J.Maddon (12-31)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}