$re = '/\p{L}.*?(?=\s*\()/';
$str = 'M.Joan (13-2)
A.Alfred (20-13)
F.O\'Neil (12-231)
D.Dan Fun (23-3)
T.Collins (51-82) J.Maddon (12-31)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);