re = /\p{L}.*?(?=\s*\()/
str = 'M.Joan (13-2)
A.Alfred (20-13)
F.O\'Neil (12-231)
D.Dan Fun (23-3)
T.Collins (51-82) J.Maddon (12-31)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end