using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!"")(?<=\w)\b(?!\s[\w]+[""*])(?![""*])";
string input = @"Bye ""cruel world"". dont* say goodbye
Bye ""cruel world"". dont* say*d goodbye*";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}