re = /(?<!")(?<=\w)\b(?!\s[\w]+["*])(?!["*])/m
str = 'Bye "cruel world". dont* say goodbye
Bye "cruel world". dont* say*d goodbye*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end