$re = '/(?<!")(?<=\w)\b(?!\s[\w]+["*])(?!["*])/m';
$str = 'Bye "cruel world". dont* say goodbye
Bye "cruel world". dont* say*d goodbye*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);