#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((((\+?\d)|(8))(\D){0,2})?\d{1}((((\D){0,2})(\d{1})){9}))\b"
Local $sString = "Самопальное праверко поиска хуй-пайми-каг написанных намирофф:" & @CRLF & _
"" & @CRLF & _
"пример текста +7961-970(01)02 пример текста ер текста +7961-970(01)02 пр" & @CRLF & _
"пример текста 81234567890 пример текста ста 81234567890 п" & @CRLF & _
"пример текста8819822198" & @CRLF & _
"" & @CRLF & _
"+7961-970(01)02 81234567890" & @CRLF & _
"81234567890" & @CRLF & _
"" & @CRLF & _
"Кантрольный пример для проверки из Интернета (выдрано "каг было" ис праверки чьей-то другой регулярки, катороя мне паказалась неудачьной):" & @CRLF & _
"" & @CRLF & _
"------------------------------------------------------------------------------------" & @CRLF & _
"Ориентировано на российские мобильные + городские с кодом из 3 цифр (например, Москва)." & @CRLF & _
"" & @CRLF & _
"Зеленый свет для:" & @CRLF & _
"------------" & @CRLF & _
"+79261234567" & @CRLF & _
"89261234567" & @CRLF & _
"79261234567" & @CRLF & _
"+7 926 123 45 67" & @CRLF & _
"------------" & @CRLF & _
"8(926)123-45-67" & @CRLF & _
"9261234567" & @CRLF & _
"79261234567" & @CRLF & _
"(495)1234567" & @CRLF & _
"------------" & @CRLF & _
"(495) 123 45 67" & @CRLF & _
"89261234567" & @CRLF & _
"8-926-123-45-67" & @CRLF & _
"8 927 1234 234" & @CRLF & _
"------------" & @CRLF & _
"8 927 12 12 888" & @CRLF & _
"8 927 12 555 12" & @CRLF & _
"8 927 123 8 123" & @CRLF & _
"926-123-45-67" & @CRLF & _
"" & @CRLF & _
"UPD: спасибо Nutochka, bask и остальным участникам дискуссии: вместе мы нашли истину. Пусть регулярка теперь стала не такой критичной, но больше клиентов смогут ввести номер." & @CRLF & _
"" & @CRLF & _
"UPD 2: и отдельное «спасибо» всем, кто спусти" & @CRLF & _
"------------------------------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"Баг 1: Некатарые IP-адреса могут распарсиццо як мабильные телефоны, пример команды подключения к серваку Quake-III-Arena (DeFRaG Mode):" & @CRLF & _
"" & @CRLF & _
"connect 88.198.221.98:27964" & @CRLF & _
"" & @CRLF & _
"При канвертации етат адрес будет испорчен, преабразаваффшысь ф:" & @CRLF & _
"" & @CRLF & _
"connect "881-982-21-98" [ +78819822198 ] :27964" & @CRLF & _
"" & @CRLF & _
"Баг 2: Нумерованные списки могут быть исталкованы неправельно, если цыфры списка адделяюццо ат номера телефона менее чем тримя нецыфравыми симваламе:" & @CRLF & _
"" & @CRLF & _
"1)текст" & @CRLF & _
"2)текст" & @CRLF & _
"..." & @CRLF & _
"8)"881-982-21-98"" & @CRLF & _
"" & @CRLF & _
"Результат канвертации:" & @CRLF & _
"" & @CRLF & _
"1)текст" & @CRLF & _
"2)текст" & @CRLF & _
"..." & @CRLF & _
""881-982-21-98" [ +78819822198 ] "" & @CRLF & _
"" & @CRLF & _
"Цыфра нумерованнава списка праебалась фместе с разделителем скобкой, если убрать из конца выражения символ границы слова "\b", то цыфра списка исчо и может быть захвачена фместо цыфер намирофф, а паследняя цыфирь номера - праигнорена (шо косяк исчо бОльшый), сопсна, для таво симвал канца слова и был дабафлен." & @CRLF & _
"" & @CRLF & _
"Ф текусчем вореанте дастаточьна дабаветь любой третий нецыфравой символ, каторый будет адделять цыфры списка ат цыфирь номера:" & @CRLF & _
"" & @CRLF & _
"1)текст" & @CRLF & _
"2)текст" & @CRLF & _
"..." & @CRLF & _
"8) "881-982-21-98"" & @CRLF & _
"" & @CRLF & _
"Терь парсиццо верно:" & @CRLF & _
"" & @CRLF & _
"1)текст" & @CRLF & _
"2)текст" & @CRLF & _
"..." & @CRLF & _
"8) ""881-982-21-98" [ +78819822198 ] "" & @CRLF & _
"" & @CRLF & _
"Лишняя кавычька - скарей косяк VBA-шнава кода, а не регулярки." & @CRLF & _
"" & @CRLF & _
"Па састайанию на сичяз выражение ф текусчем виде йафляецо дастаточьным для ришения тикусчих задач, фиксафф не плонируеццо."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")