// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((((\+?\d)|(8))(\D){0,2})?\d{1}((((\D){0,2})(\d{1})){9}))\b").unwrap();
let string = "Самопальное праверко поиска хуй-пайми-каг написанных намирофф:
пример текста +7961-970(01)02 пример текста ер текста +7961-970(01)02 пр
пример текста 81234567890 пример текста ста 81234567890 п
пример текста8819822198
+7961-970(01)02 81234567890
81234567890
Кантрольный пример для проверки из Интернета (выдрано \"каг было\" ис праверки чьей-то другой регулярки, катороя мне паказалась неудачьной):
------------------------------------------------------------------------------------
Ориентировано на российские мобильные + городские с кодом из 3 цифр (например, Москва).
Зеленый свет для:
------------
+79261234567
89261234567
79261234567
+7 926 123 45 67
------------
8(926)123-45-67
9261234567
79261234567
(495)1234567
------------
(495) 123 45 67
89261234567
8-926-123-45-67
8 927 1234 234
------------
8 927 12 12 888
8 927 12 555 12
8 927 123 8 123
926-123-45-67
UPD: спасибо Nutochka, bask и остальным участникам дискуссии: вместе мы нашли истину. Пусть регулярка теперь стала не такой критичной, но больше клиентов смогут ввести номер.
UPD 2: и отдельное «спасибо» всем, кто спусти
------------------------------------------------------------------------------------
Баг 1: Некатарые IP-адреса могут распарсиццо як мабильные телефоны, пример команды подключения к серваку Quake-III-Arena (DeFRaG Mode):
connect 88.198.221.98:27964
При канвертации етат адрес будет испорчен, преабразаваффшысь ф:
connect \"881-982-21-98\" [ +78819822198 ] :27964
Баг 2: Нумерованные списки могут быть исталкованы неправельно, если цыфры списка адделяюццо ат номера телефона менее чем тримя нецыфравыми симваламе:
1)текст
2)текст
...
8)\"881-982-21-98\"
Результат канвертации:
1)текст
2)текст
...
\"881-982-21-98\" [ +78819822198 ] \"
Цыфра нумерованнава списка праебалась фместе с разделителем скобкой, если убрать из конца выражения символ границы слова \"\\b\", то цыфра списка исчо и может быть захвачена фместо цыфер намирофф, а паследняя цыфирь номера - праигнорена (шо косяк исчо бОльшый), сопсна, для таво симвал канца слова и был дабафлен.
Ф текусчем вореанте дастаточьна дабаветь любой третий нецыфравой символ, каторый будет адделять цыфры списка ат цыфирь номера:
1)текст
2)текст
...
8) \"881-982-21-98\"
Терь парсиццо верно:
1)текст
2)текст
...
8) \"\"881-982-21-98\" [ +78819822198 ] \"
Лишняя кавычька - скарей косяк VBA-шнава кода, а не регулярки.
Па састайанию на сичяз выражение ф текусчем виде йафляецо дастаточьным для ришения тикусчих задач, фиксафф не плонируеццо.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}