import re
regex = re.compile(r"((((\+?\d)|(8))(\D){0,2})?\d{1}((((\D){0,2})(\d{1})){9}))\b", flags=re.MULTILINE)
test_str = ("Самопальное праверко поиска хуй-пайми-каг написанных намирофф:\n\n"
"пример текста +7961-970(01)02 пример текста ер текста +7961-970(01)02 пр\n"
"пример текста 81234567890 пример текста ста 81234567890 п\n"
"пример текста8819822198\n\n"
"+7961-970(01)02 81234567890\n"
"81234567890\n\n"
"Кантрольный пример для проверки из Интернета (выдрано \"каг было\" ис праверки чьей-то другой регулярки, катороя мне паказалась неудачьной):\n\n"
"------------------------------------------------------------------------------------\n"
"Ориентировано на российские мобильные + городские с кодом из 3 цифр (например, Москва).\n\n"
"Зеленый свет для:\n"
"------------\n"
"+79261234567\n"
"89261234567\n"
"79261234567\n"
"+7 926 123 45 67\n"
"------------\n"
"8(926)123-45-67\n"
"9261234567\n"
"79261234567\n"
"(495)1234567\n"
"------------\n"
"(495) 123 45 67\n"
"89261234567\n"
"8-926-123-45-67\n"
"8 927 1234 234\n"
"------------\n"
"8 927 12 12 888\n"
"8 927 12 555 12\n"
"8 927 123 8 123\n"
"926-123-45-67\n\n"
"UPD: спасибо Nutochka, bask и остальным участникам дискуссии: вместе мы нашли истину. Пусть регулярка теперь стала не такой критичной, но больше клиентов смогут ввести номер.\n\n"
"UPD 2: и отдельное «спасибо» всем, кто спусти\n"
"------------------------------------------------------------------------------------\n\n"
"Баг 1: Некатарые IP-адреса могут распарсиццо як мабильные телефоны, пример команды подключения к серваку Quake-III-Arena (DeFRaG Mode):\n\n"
"connect 88.198.221.98:27964\n\n"
"При канвертации етат адрес будет испорчен, преабразаваффшысь ф:\n\n"
"connect \"881-982-21-98\" [ +78819822198 ] :27964\n\n"
"Баг 2: Нумерованные списки могут быть исталкованы неправельно, если цыфры списка адделяюццо ат номера телефона менее чем тримя нецыфравыми симваламе:\n\n"
"1)текст\n"
"2)текст\n"
"...\n"
"8)\"881-982-21-98\"\n\n"
"Результат канвертации:\n\n"
"1)текст\n"
"2)текст\n"
"...\n"
"\"881-982-21-98\" [ +78819822198 ] \"\n\n"
"Цыфра нумерованнава списка праебалась фместе с разделителем скобкой, если убрать из конца выражения символ границы слова \"\\b\", то цыфра списка исчо и может быть захвачена фместо цыфер намирофф, а паследняя цыфирь номера - праигнорена (шо косяк исчо бОльшый), сопсна, для таво симвал канца слова и был дабафлен.\n\n"
"Ф текусчем вореанте дастаточьна дабаветь любой третий нецыфравой символ, каторый будет адделять цыфры списка ат цыфирь номера:\n\n"
"1)текст\n"
"2)текст\n"
"...\n"
"8) \"881-982-21-98\"\n\n"
"Терь парсиццо верно:\n\n"
"1)текст\n"
"2)текст\n"
"...\n"
"8) \"\"881-982-21-98\" [ +78819822198 ] \"\n\n"
"Лишняя кавычька - скарей косяк VBA-шнава кода, а не регулярки.\n\n"
"Па састайанию на сичяз выражение ф текусчем виде йафляецо дастаточьным для ришения тикусчих задач, фиксафф не плонируеццо.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")