using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[][:* ?\/\\]{1,}";
string substitution = @"#";
string input = @"Test?:? now: and a[problem] here.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}