import re
regex = re.compile(r"[][:* ?\/\\]{1,}", flags=re.MULTILINE)
test_str = "Test?:? now: and a[problem] here."
subst = "#"
result = regex.sub(subst, test_str)
if result:
print(result)