const regex = /[][:* ?\/\\]{1,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[][:* ?\\\/\\\\]{1,}', 'gm')
const str = `Test?:? now: and a[problem] here.`;
const subst = `#`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);