$re = '/\b(?!(?:\w*(\w)\1){3})\w+\b/m';
$str = 'adminnisstrator21
kkeeykloakk
stack22ooverflow
blahbllahhblaafaa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);