re = /\b(?!(?:\w*(\w)\1){3})\w+\b/m
str = 'adminnisstrator21
kkeeykloakk
stack22ooverflow
blahbllahhblaafaa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end