const regex = /(?!0)(\d)(?!\d)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!0)(\\d)(?!\\d)$', 'gm')
const str = `File_10
File_2
File_3
File_4`;
const subst = `0$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);