use strict;
my $str = 'File_10
File_2
File_3
File_4';
my $regex = qr/(?!0)(\d)(?!\d)$/mp;
my $subst = '0$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";