re = /(?!0)(\d)(?!\d)$/m
str = 'File_10
File_2
File_3
File_4'
subst = '0$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result