package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*(\s*\|\s*(?<captureMe>[^\|]+)\|\s*)`)
var str = `a|ABC|xx
a |ABC|xx
a |ABC| xx
a | ABC| xx
a | ABC | xx
a | A B C | xx
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}