$re = '/\s*(\s*\|\s*(?<captureMe>[^\|]+)\|\s*)/';
$str = 'a|ABC|xx
a |ABC|xx
a |ABC| xx
a | ABC| xx
a | ABC | xx
a | A B C | xx
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);