re = /\s*(\s*\|\s*(?<captureMe>[^\|]+)\|\s*)/
str = 'a|ABC|xx
a |ABC|xx
a |ABC| xx
a | ABC| xx
a | ABC | xx
a | A B C | xx
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end