package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^]]+\]`)
var str = `$string = "I have some fruits like [name], [another_name] and [one_another_name]";
`
var substitution = "%s"
fmt.Println(re.ReplaceAllString(str, substitution))
}