import Foundation
let pattern = #"\[[^]]+\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
$string = "I have some fruits like [name], [another_name] and [one_another_name]";
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"%s"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)