$re = '/\[[^]]+\]/m';
$str = '$string = "I have some fruits like [name], [another_name] and [one_another_name]";
';
$subst = "%s";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;