use strict;
my $str = 'var массив = [
]';
my $regex = qr/\s{2,}/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";