use strict;
my $str = 'var массив = [
1
]';
my $regex = qr/\n{2,}/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";