package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:\d){1,3}(?:\.\d{1,3}){0,8})`)
var str = `1 text
1.1 text 2
1.2 text 3
2 text 2
3 text 3
3.1 text 3.1
second string of 3.1
third string of 3.1
4.1.2.3.4.5
4.1.2.3.4.5.6.7.8
//I used .split() method to get multiline text from numbered list`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}