// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:\d){1,3}(?:\.\d{1,3}){0,8})").unwrap();
let string = "1 text
1.1 text 2
1.2 text 3
2 text 2
3 text 3
3.1 text 3.1
second string of 3.1
third string of 3.1
4.1.2.3.4.5
4.1.2.3.4.5.6.7.8
//I used .split() method to get multiline text from numbered list";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}