#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^.]+$|\.(?!(jpg|gif|svg)$)([^.]+$)"
Local $sString = "file.jpg" & @CRLF & _
"file.png" & @CRLF & _
"file.svg" & @CRLF & _
"file.js" & @CRLF & _
"file.gif" & @CRLF & _
"file.psd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")