using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^.]+$|\.(?!(jpg|gif|svg)$)([^.]+$)";
string input = @"file.jpg
file.png
file.svg
file.js
file.gif
file.psd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}