$re = '/^[^.]+$|\.(?!(jpg|gif|svg)$)([^.]+$)/m';
$str = 'file.jpg
file.png
file.svg
file.js
file.gif
file.psd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);