import re
regex = re.compile(r"^(?!'{NSVue)(.)*(')$", flags=re.MULTILINE)
test_str = ("'getFrameById() is deprecated. Use Frame.getFrameById() instead.'\n"
"'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> CreateElement(NativePage)'\n"
"'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> CreateElement(NativeActionBar)'\n"
"'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> CreateElement(nativenavigationbutton)'\n"
"'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> AppendChild(ElementNode(nativeactionbar), ElementNode(nativenavigationbutton))'\n"
"'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> CreateElement(nativeactionitem)'\n"
"'{NSVue (Vue: 2.6.10 | NSVue: 2.4.0)} -> AppendChild(ElementNode(nativeactionbar), ElementNode(nativeactionitem))'")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)