#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([^:]++): [[]([^]]++)[]]>[[]([^]]++)[]]<[[]([^]]++)[]]([^[]++)[[]([^]]++)[]]"
Local $sString = "RMS Power : [ 0.00]>[ 2.83]<[ 4.00]dBm [PASS]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")