package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^:]++): [[]([^]]++)[]]>[[]([^]]++)[]]<[[]([^]]++)[]]([^[]++)[[]([^]]++)[]]`)
var str = `RMS Power : [ 0.00]>[ 2.83]<[ 4.00]dBm [PASS]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}