$re = '/([^:]++): [[]([^]]++)[]]>[[]([^]]++)[]]<[[]([^]]++)[]]([^[]++)[[]([^]]++)[]]/';
$str = 'RMS Power : [ 0.00]>[ 2.83]<[ 4.00]dBm [PASS]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);