$re = '/(^\'{3}(?:[^\\\\]|\\\\[\s\S])*(?:\'{3}$))/m';
$str = '\'\'\' \'This "is" my\' && "first \'regex\' sentence." \'\'\' &&
\'\'\' \'This "is" the second.\' \'\'\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);