import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\d*000)\\d+$";
final String string = "001234567502344001233400122300\n"
+ "0123456750023440012334012230\n"
+ "000123456750234400123340012230\n"
+ "001234567502344000123340012230\n"
+ "0012345675023440012334001223000\n"
+ "00123456750234400012334001223000\n"
+ "001002003004005006\n"
+ "000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}