const regex = /^(?=(?:[^\d\n]*\d){0,12}[^\d\n]*$)\d*[.]?\d{0,6}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:[^\\d\\n]*\\d){0,12}[^\\d\\n]*$)\\d*[.]?\\d{0,6}$', 'gm')
const str = `1.22
1.234567
123456789012
1234567.9012
123456789012
1234567890123
1.2345678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}