$re = '/^(?=(?:[^\d\n]*\d){0,12}[^\d\n]*$)\d*[.]?\d{0,6}$/m';
$str = '1.22
1.234567
123456789012
1234567.9012
123456789012
1234567890123
1.2345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);