$re = '/(?i:([;]|^)([a-z0-9.]+@(dom\.net|part1\.part2\.uk))(?=[;]|$))/';
$str = 'a.name@part1.part2.uk;a.name@dom.net';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);