import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(subdomain1\\.|subdomain2\\.)?(((?<branch>(?!subdomain1|subdomain2).+)\\.|)staging\\.com)$";
final String string = "subdomain1.branch-name.staging.com\n"
+ "subdomain1.branch-name-with-subdomain1.staging.com\n"
+ "subdomain2.subdomain1.staging.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}