re = /^(subdomain1\.|subdomain2\.)?(((?<branch>(?!subdomain1|subdomain2).+)\.|)staging\.com)$/m
str = 'subdomain1.branch-name.staging.com
subdomain1.branch-name-with-subdomain1.staging.com
subdomain2.subdomain1.staging.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end