const regex = /^(subdomain1\.|subdomain2\.)?(((?<branch>(?!subdomain1|subdomain2).+)\.|)staging\.com)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(subdomain1\\.|subdomain2\\.)?(((?<branch>(?!subdomain1|subdomain2).+)\\.|)staging\\.com)$', 'gm')
const str = `subdomain1.branch-name.staging.com
subdomain1.branch-name-with-subdomain1.staging.com
subdomain2.subdomain1.staging.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}