import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^?]*$";
final String string = "https://stackoverflow.com/questions/ask/submit?search=cedar\n"
+ "https://stackoverflow.com/questions/61282240/extracting-the-string-after-the-last-in-google-data-studio-regexp-problem?id=5677878";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}