const regex = /[^?]*$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^?]*$', 'mg')
const str = `https://stackoverflow.com/questions/ask/submit?search=cedar
https://stackoverflow.com/questions/61282240/extracting-the-string-after-the-last-in-google-data-studio-regexp-problem?id=5677878`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}