re = /[^?]*$/m
str = 'https://stackoverflow.com/questions/ask/submit?search=cedar
https://stackoverflow.com/questions/61282240/extracting-the-string-after-the-last-in-google-data-studio-regexp-problem?id=5677878'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end