const regex = /^[a-z]+(?:[ ,'-][a-z]+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z]+(?:[ ,\'-][a-z]+)*$', 'gm')
const str = `hello
what
how are you
how are you?
hi5
8ask
yyyy.
! dff
NoSpecialcharacters#
54445566
how are you
how-are-you
how-are------you
the person's thing
the person''s thing
how, are you
how,, are you`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}