// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z]+(?:[ ,'-][a-z]+)*$").unwrap();
let string = "hello
what
how are you
how are you?
hi5
8ask
yyyy.
! dff
NoSpecialcharacters#
54445566
how are you
how-are-you
how-are------you
the person's thing
the person''s thing
how, are you
how,, are you";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}