$re = '/^[a-z]+(?:[ ,\'-][a-z]+)*$/m';
$str = 'hello
what
how are you
how are you?
hi5
8ask
yyyy.
! dff
NoSpecialcharacters#
54445566
how are you
how-are-you
how-are------you
the person\'s thing
the person\'\'s thing
how, are you
how,, are you';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);