using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"geo:-?[0-9]{1,2}\.[0-9]*,-?[0-9]{1,3}\.?[0-9]*(;u=[0-9]{1,2})?";
string input = @"geo:37.786971,-122.399677
geo:37.786971,-122.399677;u=35";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}